Microphone issues2021-04-21T08:35:40+01:00
672 viewsWindows 10
0

My computer, currently running windows 10, refuses to accept any audio from any microphone. A few months ago I bought a razor headset with separate input and output jacks, and managed to get my computer working with it. Now after having sparingly used my pc for the past few months my computer refuses to take any input from either of the two microphones I tested. I know it’s not the mics that don’t work as I was able to run them on other machines. I’ve panned through every help thread I was able to find on the subject and nothing helped. My drivers are up to date, the mic is enabled, detected, and said to be functional under every menu I could access. Troubleshooting turns up nothing. No the mic isn’t just “muted”. I’m at a loss here, I’m afraid there’s an issue with my motherboard or pc case, if anyone has tips or a suggestion it would be welcomed.


Changed status to publish
0

Here is a troubleshooting guide. Razer Kraken X Support
Make sure the Mic is not Muted as outlined in this page. If everything fails, contact Razors support.

Changed status to publish
0

Thanks for the response, I have tried all audio ports both front and back on my pc, getting no success out of any. I have not tried getting drivers directly from the razor website though. The mic is listed and enabled under the recording tab, though no sound is picked up as I speak into the mic. The model is the Kraken X.

Changed status to publish
0

What is the make and model# of the Razor Headsets? Did you update your drivers from the Razer page? Hopefully you don’t have both mics plugged in at the same time, as this would confuse the system and negate the response. Are you plugging this into the Back audio ports and not the Front of your Desktop computer? Sometimes it works better plugged in the back.
When you have the headset plugged in, press the Windows key+S and in the search box type Control Panel and press Enter, then go to Sound. Go to the Recording tab. If your Mic listed here? Make sure it is listed as the Default Mic for recording. If so, select it and then choose Configure go thru the tests.

Changed status to publish

Question stats

  • Active
  • Views672 times
  • Answers3 answers