Windows 7: How to stop searchindexer.exe from coming back on?2021-04-20T08:25:29+01:00
539 viewsWindows 7
0

Windows Search is a service that I want to run, but a component of this, searchindexer.exe is supposed to be possible to disable if you don’t need indexing of files. The Windows Search service does much more than this, so I don’t want to disable the whole thing, just the indexing of files (if you’re curious why, it’s mostly because I suspect it’s writing and reading the hard drive and the constant clicking and buzzing noise is too annoying).


What did I already try:

1. You’re supposed to be able to go to Control Panel > All Control Panel Items > Programs and Features > Turn Windows Features On or Off >  go to “Indexing Service” and uncheck the box. Also, scroll down to “Windows Search” I can see the check is still there, which I want so that I can still search for files (without the indexing feature).

2. I go to Start > open Computer > Hard Disk Drives > Properties  and I uncheck “Allow files on this drive to have contents indexed…”

3. I go to Start > Computer > Manage > Services and Applications > Services  and “Windows Search” is set on Manual.

Changed status to publish
0

This disables ALL Windows Search services, including the Start Menu search and folder search services. There is supposed to be a way to keep Windows Search service on manual and only stop the SearchIndexer.exe. Disabling Windows Search means every time you want to search for a file you have to go back and turn the Windows Search option back on.

Avast scan (including a boot scan) and Malwarebytes both indicate no virus, malware, or pup.

I disabled Windows Search for a test today, and it appears the hard drive activity has not been as high. I’m wondering too if the problem is low RAM (I’ve got 2 GB at the moment, which I think is the minimum recommended for Windows 7) with high page file usage, but I can see there’s still available RAM at the Task Manager > Performance tab.  I’m going to be installing more memory very soon anyway and will have 8GB total.

Changed status to publish
0

Instead of setting Windows Search to manual in services, set it to Disabled.

Changed status to publish

Question stats

  • Active
  • Views539 times
  • Answers2 answers