Mouse/Keyboard cease to work2021-04-19T10:23:50+01:00
560 viewsHardware Issues
0

Dell Laptop  (Alienware Area51)


OK, this issue always starts with a warning box appearing during use saying “USB device not recognized” and the Logitech wireless USB Mouse ceasing to work. Then you find the on board laptop keyboard is not working either. Sometimes but rarely this will correct itself while faulting. (The mouse works with no issues on another laptop).

Sometimes the Mouse will not reconnect by removal/replacement of the USB dongle, sometimes it will. The laptop pad works without issue all the time.

Sometimes the keyboard will not work again, and only rarely will it restart on a reboot.

More and more frequently the keyboard and mouse are ceasing to work and not recovering on reboot.

While the issue is on, going into the BIOS and moving around menus shows that the keyboard hardware is OK even when it will not work in Windows.

I get out of the issue by using the laptop’s keypad and plugging in a remote USB keyboard to get back in past the PIN screen and uninstall the keyboard drivers.

It then will work OK for sometimes many weeks.

For completeness I should add that I run a USB device sometimes (maybe once a month) that will not work to the “Better USB Driver”, I have to revert the driver. This device and the whole machine then work perfectly OK, but the next Windows Update always changes the driver back to the “Better USB Driver” again.  I’m pretty sure that this is not the cause, as the issue can arise regardless of which USB driver is in use.

I’m writing this on that laptop using the onboard keyboard and the mouse after yet again being forced to get back in and remove drivers, and its working perfeectly again………….. for now!

Is there anything I can do on this laptop to better investigate and stop this recurring issue please?

Changed status to publish
0

Press the Power button to turn on  your computer. Once you power on the computer, keep pressing the F8 key on your keyboard in 1 second intervals.  (If you computer has already turned on, turn it off then press the Power button to turn it on again.)

When the Advanced Boot Options screen displays, use the arrow key to select Disable Driver Signature Enforcement.

Changed status to publish

Question stats

  • Active
  • Views560 times
  • Answers1 answer